#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)(?(DEFINE)" & @CRLF & _
" (?<ns>[ns])" & @CRLF & _
" (?<ew>[ew])" & @CRLF & _
" (?<d>[°´’'"d:])" & @CRLF & _
" (?<n>[+-]?\d+(?:\.\d+)?)" & @CRLF & _
")" & @CRLF & _
"(" & @CRLF & _
" (?&ns)?" & @CRLF & _
" (?:\ ?(?&n)(?&d)?){1,3}" & @CRLF & _
" \ ?(?&ns)?" & @CRLF & _
")" & @CRLF & _
"\ ?,?\ ?" & @CRLF & _
"(" & @CRLF & _
" (?&ew)?" & @CRLF & _
" (?:\ ?(?&n)(?&d)?){1,3}" & @CRLF & _
" \ ?(?&ew)?" & @CRLF & _
")"
Local $sString = "N 45° 55.732 W 122° 29.882" & @CRLF & _
"N 047° 38.938', W 122° 20.887'" & @CRLF & _
"40.123, -74.123" & @CRLF & _
"40.123° N 74.123° W" & @CRLF & _
"40° 7´ 22.8" N 74° 7´ 22.8" W" & @CRLF & _
"40° 7.38’ , -74° 7.38’" & @CRLF & _
"N40°7’22.8, W74°7’22.8"" & @CRLF & _
"40°7’22.8"N, 74°7’22.8"W" & @CRLF & _
"40 7 22.8, -74 7 22.8" & @CRLF & _
"40.123 -74.123" & @CRLF & _
"40.123°,-74.123°" & @CRLF & _
"144442800, -266842800" & @CRLF & _
"40.123N74.123W" & @CRLF & _
"4007.38N7407.38W" & @CRLF & _
"40°7’22.8"N, 74°7’22.8"W" & @CRLF & _
"400722.8N740722.8W" & @CRLF & _
"N 40 7.38 W 74 7.38" & @CRLF & _
"40:7:23N,74:7:23W" & @CRLF & _
"40:7:22.8N 74:7:22.8W" & @CRLF & _
"40°7’23"N 74°7’23"W" & @CRLF & _
"40°7’23" -74°7’23"" & @CRLF & _
"40d 7’ 23" N 74d 7’ 23" W" & @CRLF & _
"40.123N 74.123W" & @CRLF & _
"40° 7.38, -74° 7.38"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")