import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<ns>[ns])\n"
+ " (?<ew>[ew])\n"
+ " (?<d>[°´’'\"d:])\n"
+ " (?<n>[+-]?\\d+(?:\\.\\d+)?)\n"
+ ")\n"
+ "(\n"
+ " (?&ns)?\n"
+ " (?:\\ ?(?&n)(?&d)?){1,3}\n"
+ " \\ ?(?&ns)?\n"
+ ")\n"
+ "\\ ?,?\\ ?\n"
+ "(\n"
+ " (?&ew)?\n"
+ " (?:\\ ?(?&n)(?&d)?){1,3}\n"
+ " \\ ?(?&ew)?\n"
+ ")";
final String string = "N 45° 55.732 W 122° 29.882\n"
+ "N 047° 38.938', W 122° 20.887'\n"
+ "40.123, -74.123\n"
+ "40.123° N 74.123° W\n"
+ "40° 7´ 22.8\" N 74° 7´ 22.8\" W\n"
+ "40° 7.38’ , -74° 7.38’\n"
+ "N40°7’22.8, W74°7’22.8\"\n"
+ "40°7’22.8\"N, 74°7’22.8\"W\n"
+ "40 7 22.8, -74 7 22.8\n"
+ "40.123 -74.123\n"
+ "40.123°,-74.123°\n"
+ "144442800, -266842800\n"
+ "40.123N74.123W\n"
+ "4007.38N7407.38W\n"
+ "40°7’22.8\"N, 74°7’22.8\"W\n"
+ "400722.8N740722.8W\n"
+ "N 40 7.38 W 74 7.38\n"
+ "40:7:23N,74:7:23W\n"
+ "40:7:22.8N 74:7:22.8W\n"
+ "40°7’23\"N 74°7’23\"W\n"
+ "40°7’23\" -74°7’23\"\n"
+ "40d 7’ 23\" N 74d 7’ 23\" W\n"
+ "40.123N 74.123W\n"
+ "40° 7.38, -74° 7.38";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}