# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)
(?<ns>[ns])
(?<ew>[ew])
(?<d>[°´’'"d:])
(?<n>[+-]?\d+(?:\.\d+)?)
)
(
(?&ns)?
(?:\ ?(?&n)(?&d)?){1,3}
\ ?(?&ns)?
)
\ ?,?\ ?
(
(?&ew)?
(?:\ ?(?&n)(?&d)?){1,3}
\ ?(?&ew)?
)
"""
test_str = ("N 45° 55.732 W 122° 29.882\n"
"N 047° 38.938', W 122° 20.887'\n"
"40.123, -74.123\n"
"40.123° N 74.123° W\n"
"40° 7´ 22.8\" N 74° 7´ 22.8\" W\n"
"40° 7.38’ , -74° 7.38’\n"
"N40°7’22.8, W74°7’22.8\"\n"
"40°7’22.8\"N, 74°7’22.8\"W\n"
"40 7 22.8, -74 7 22.8\n"
"40.123 -74.123\n"
"40.123°,-74.123°\n"
"144442800, -266842800\n"
"40.123N74.123W\n"
"4007.38N7407.38W\n"
"40°7’22.8\"N, 74°7’22.8\"W\n"
"400722.8N740722.8W\n"
"N 40 7.38 W 74 7.38\n"
"40:7:23N,74:7:23W\n"
"40:7:22.8N 74:7:22.8W\n"
"40°7’23\"N 74°7’23\"W\n"
"40°7’23\" -74°7’23\"\n"
"40d 7’ 23\" N 74d 7’ 23\" W\n"
"40.123N 74.123W\n"
"40° 7.38, -74° 7.38")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.