const regex = /(?:^\(|\G(?!^)(?:\) | \())\K(?:(?:and|or)|[^)]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\(|\\G(?!^)(?:\\) | \\())\\K(?:(?:and|or)|[^)]+)', 'gm')
const str = `(Field1 = 'Val and ue1') and (Field2 = 'Valu or e2') or (Field3 = 'Value3')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}