re = /(?:^\(|\G(?!^)(?:\) | \())\K(?:(?:and|or)|[^)]+)/m
str = '(Field1 = \'Val and ue1\') and (Field2 = \'Valu or e2\') or (Field3 = \'Value3\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end