$re = '/(?:^\(|\G(?!^)(?:\) | \())\K(?:(?:and|or)|[^)]+)/m';
$str = '(Field1 = \'Val and ue1\') and (Field2 = \'Valu or e2\') or (Field3 = \'Value3\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);