const regex = /"uf":"([^"]+)(?!.*dating[1,2])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"uf":"([^"]+)(?!.*dating[1,2])', 'gm')
const str = `[{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=776108&mid=0","ttl":"Sarah (31) 1 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/Ff89Uqu0t0q-Ic97IVjQaovVMiroHWrm.png","tn":""}],"rinfo":{"rw":"/wnrw?aid=2906583808848052910","rc":""}},{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=770131&mid=1","ttl":"Brittany (30) 3 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/h41dZhp8C7mIiHIIdXGZ9gSAZ1ZQjD0T.png","tn":"dating2"}],"rinfo":{"rw":"","rc":""}}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}