import Foundation
let pattern = #""uf":"([^"]+)(?!.*dating[1,2])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=776108&mid=0","ttl":"Sarah (31) 1 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/Ff89Uqu0t0q-Ic97IVjQaovVMiroHWrm.png","tn":""}],"rinfo":{"rw":"/wnrw?aid=2906583808848052910","rc":""}},{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=770131&mid=1","ttl":"Brittany (30) 3 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/h41dZhp8C7mIiHIIdXGZ9gSAZ1ZQjD0T.png","tn":"dating2"}],"rinfo":{"rw":"","rc":""}}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)