re = /"uf":"([^"]+)(?!.*dating[1,2])/m
str = '[{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=776108&mid=0","ttl":"Sarah (31) 1 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/Ff89Uqu0t0q-Ic97IVjQaovVMiroHWrm.png","tn":""}],"rinfo":{"rw":"/wnrw?aid=2906583808848052910","rc":""}},{"ads":[{"uf":"https://prhzxq.com/wnclcm?aid=2906583808848052910&t=1659642044&s=770131&mid=1","ttl":"Brittany (30) 3 km from you","n":"Hey, do you want to come? 😉😘","gf":"","ic":"https://i.wmgtr.com/cic/h41dZhp8C7mIiHIIdXGZ9gSAZ1ZQjD0T.png","tn":"dating2"}],"rinfo":{"rw":"","rc":""}}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end