package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b( )\b`)
var str = `test a one.
test a two.
test a three.
test a four.
test a five.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}