using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\\]*)""";
string substitution = @"$1$1\\""";
string input = @"{ ""name"": ""Nat \""King\"" Cole"" } ";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}