const regex = new RegExp('([\\\\]*)""', 'gi')
const str = `{ "name": "Nat \\"King\\" Cole" } `;
const subst = `$1$1\\"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);