re = /([\\]*)""/i
str = '{ "name": "Nat \\"King\\" Cole" } '
subst = '$1$1\\\\"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result