using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]+\b)(?!.+\1[,|$])";
string input = @"java,NO,C,Node,ReactJs,c,Spring,undefined,asdja,Java,Spring,adjasjh,adjasjh,java,java-script
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}