re = /([^,]+\b)(?!.+\1[,|$])/mi
str = 'java,NO,C,Node,ReactJs,c,Spring,undefined,asdja,Java,Spring,adjasjh,adjasjh,java,java-script
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end