$re = '/([^,]+\b)(?!.+\1[,|$])/mi';
$str = 'java,NO,C,Node,ReactJs,c,Spring,undefined,asdja,Java,Spring,adjasjh,adjasjh,java,java-script
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);