import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^/]*/(?!admin/)(?:[^/\\n]+/)+$";
final String string = "localhost:8000/admin/mymodel/something/\n"
+ "localhost:8000/something\n"
+ "localhost:8000/something/\n"
+ "localhost:8000/something/something/something/\n"
+ "localhost:8000\n"
+ "something/\n"
+ "/someting/a/\n"
+ "/someting//a/a/\n"
+ "/someting//\n"
+ "/someting//something//\n"
+ "/someting/something//\n"
+ "/someting//something//\n"
+ "something/something/\n"
+ "something/admin/something/\n"
+ "/something/admin/something/\n"
+ "/admin/\n"
+ "/admin/green/yellow/\n"
+ "/admin/hello/\n"
+ "/admin/hello/hello/\n"
+ "/admin/hello/hello/hello/\n"
+ "/admin/hello/hello\n"
+ "admin/\n"
+ "admin/green/yellow/\n"
+ "admin/hello/\n"
+ "/notadmin/path/something\n"
+ "/something/admin/something/\n"
+ "/what/is/happening/\n"
+ "/no_admin/yellow/\n"
+ "/no_admin/yellow/green/red/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}