import re
regex = re.compile(r"^[^/]*/(?!admin/)(?:[^/\n]+/)+$", flags=re.MULTILINE)
test_str = ("localhost:8000/admin/mymodel/something/\n"
"localhost:8000/something\n"
"localhost:8000/something/\n"
"localhost:8000/something/something/something/\n"
"localhost:8000\n"
"something/\n"
"/someting/a/\n"
"/someting//a/a/\n"
"/someting//\n"
"/someting//something//\n"
"/someting/something//\n"
"/someting//something//\n"
"something/something/\n"
"something/admin/something/\n"
"/something/admin/something/\n"
"/admin/\n"
"/admin/green/yellow/\n"
"/admin/hello/\n"
"/admin/hello/hello/\n"
"/admin/hello/hello/hello/\n"
"/admin/hello/hello\n"
"admin/\n"
"admin/green/yellow/\n"
"admin/hello/\n"
"/notadmin/path/something\n"
"/something/admin/something/\n"
"/what/is/happening/\n"
"/no_admin/yellow/\n"
"/no_admin/yellow/green/red/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")