$re = '/filename=(.*)/m';
$str = 'attachment; filename=InformeAuditoria_20200518103457.xlsx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);