re = /filename=(.*)/m
str = 'attachment; filename=InformeAuditoria_20200518103457.xlsx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end