use strict;
my $str = '2,564.30
-2,564.30';
my $regex = qr/^-\K|[^-\d\n.]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";