$re = '/^-\K|[^-\d\n.]/m';
$str = '2,564.30
-2,564.30';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;