#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)table1(?!\d)"
Local $sString = "this is a test table1 found" & @CRLF & _
"This is another test table1(some other data here)" & @CRLF & _
"thistable1shouldbeincluded" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"this is a text table10 found" & @CRLF & _
"table10is here" & @CRLF & _
"testing this should not be included table18(testing)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")