re = /table1(?!\d)/m
str = 'this is a test table1 found
This is another test table1(some other data here)
thistable1shouldbeincluded
this is a text table10 found
table10is here
testing this should not be included table18(testing)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end