$re = '/table1(?!\d)/m';
$str = 'this is a test table1 found
This is another test table1(some other data here)
thistable1shouldbeincluded
this is a text table10 found
table10is here
testing this should not be included table18(testing)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);