using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*?\)";
string input = @"buz one,two,ten
bas first,second,third(twenty,thirty,forty),last
bur ten,eleven,twelve
baz (foo,bar)abcg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}