// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(.*?\)").unwrap();
let string = "buz one,two,ten
bas first,second,third(twenty,thirty,forty),last
bur ten,eleven,twelve
baz (foo,bar)abcg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}