re = /\(.*?\)/m
str = 'buz one,two,ten
bas first,second,third(twenty,thirty,forty),last
bur ten,eleven,twelve
baz (foo,bar)abcg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end