using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:const\s|var\s|let\s)[^;\n]*)(?=const|var|let)";
string input = @"const asd2 = ""asd2""
const asd = ""asd""; const asd = ""asd"" {;JUMP;} const";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}