$re = '/(?<=(?:const\s|var\s|let\s)[^;\n]*)(?=const|var|let)/';
$str = 'const asd2 = "asd2"
const asd = "asd"; const asd = "asd" {;JUMP;} const';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);