import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:const\\s|var\\s|let\\s)[^;\\n]*)(?=const|var|let)";
final String string = "const asd2 = \"asd2\"\n"
+ "const asd = \"asd\"; const asd = \"asd\" {;JUMP;} const";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}