#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^.]+(?:(?:\.[^.]{2,3}){1,2}|\.[^.]+))$"
Local $sString = "google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"www.google.co.uk" & @CRLF & _
"my.fancy.subdomain.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")