import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^.]+(?:(?:\\.[^.]{2,3}){1,2}|\\.[^.]+))$";
final String string = "google.com\n"
+ "www.google.com\n"
+ "www.google.co.uk\n"
+ "my.fancy.subdomain.google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}