$re = '/([^.]+(?:(?:\.[^.]{2,3}){1,2}|\.[^.]+))$/m';
$str = 'google.com
www.google.com
www.google.co.uk
my.fancy.subdomain.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);