using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tcp\h.*?:80\h.*?\busers:\(\(""\K[^""]+(?="")";
string input = @"tcp LISTEN 0 10 0.0.0.0:80 0.0.0.0:* users:((""nc"",pid=3474,fd=4))
tcp LISTEN 0 10 [::]:80 [::]:* users:((""nc"",pid=3474,fd=3))
tcp LISTEN 0 511 *:80 *:* users:((""apache2"",pid=6741,fd=4),(""apache2"",pid=6740,fd=4),(""apache2"",pid=6738,fd=4),(""apache2"",pid=6737,fd=4),(""apache2"",pid=6736,fd=4),(""apache2"",pid=6724,fd=4))
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}