# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"tcp\h.*?:80\h.*?\busers:\(\(\"\K[^\"]+(?=\")"
test_str = ("tcp LISTEN 0 10 0.0.0.0:80 0.0.0.0:* users:((\"nc\",pid=3474,fd=4)) \n"
"tcp LISTEN 0 10 [::]:80 [::]:* users:((\"nc\",pid=3474,fd=3)) \n\n\n"
"tcp LISTEN 0 511 *:80 *:* users:((\"apache2\",pid=6741,fd=4),(\"apache2\",pid=6740,fd=4),(\"apache2\",pid=6738,fd=4),(\"apache2\",pid=6737,fd=4),(\"apache2\",pid=6736,fd=4),(\"apache2\",pid=6724,fd=4))\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.