$re = '/[.][mp3]+/m';
$str = 'lista de arquivos mp3: jazz.mp3,rock.mp3,podcast.mp3,blues.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);