#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^#(?:[\da-f]{3}){1,2}$|^#(?:[\da-f]{4}){1,2}$|(rgb|hsl)a?\((\s*-?\d+%?\s*,){2}(\s*-?\d+%?\s*)\)|(rgb|hsl)a?\((\s*-?\d+%?\s*,){3}\s*(0|(0?\.\d+)|1)\)"
Local $sString = "#ff0" & @CRLF & _
"#ff00" & @CRLF & _
"#ff00f" & @CRLF & _
"#ff00ff" & @CRLF & _
"#ff00ff0" & @CRLF & _
"#ff00ff00" & @CRLF & _
"rgb(0, 0, 0)" & @CRLF & _
"rgb(0,)" & @CRLF & _
"rgb(0 0)" & @CRLF & _
"rgb( 0, 0, 0 )" & @CRLF & _
"rgb(-100, -10, 0 )" & @CRLF & _
"rgb(0, 0, 0,)" & @CRLF & _
"rgb(-100, -10 0 )" & @CRLF & _
"rgb(-100 -10 0 , , ,)" & @CRLF & _
"rgb(100%, 100%, 100%)" & @CRLF & _
"hsl(100%, 100%, 100%, 1009)" & @CRLF & _
"rgb(0,0,0,1.2)" & @CRLF & _
"rgb(0, 0 , 0 , 1.2)" & @CRLF & _
"rgb(0,0,0, 0.4)" & @CRLF & _
"rgb(0,0,0, 0.499)" & @CRLF & _
"rgb(0, 0 , 0 )" & @CRLF & _
"rgba(0, 0, 0, 1)" & @CRLF & _
"rgba(0, 0, 0, 0)" & @CRLF & _
"rgba( 0, 0, 0, 1)" & @CRLF & _
"rgba(0, 0, 0, .45)" & @CRLF & _
"rgba(0, 0, 0, .4)" & @CRLF & _
"rgba(0,0,0, 1.2)" & @CRLF & _
"rgba(100%, 100%, 100%, 1)" & @CRLF & _
"hsl(0, 0, 0)" & @CRLF & _
"hsl(0,)" & @CRLF & _
"hsl(0 0)" & @CRLF & _
"hsl( 0, 0, 0 )" & @CRLF & _
"hsl(-100, -10, 0 )" & @CRLF & _
"hsl(-100 , -10, 0 )" & @CRLF & _
"hsl(0, 0, 0,)" & @CRLF & _
"hsl(-100, -10 0 )" & @CRLF & _
"hsl(-100 -10 0 , , ,)" & @CRLF & _
"hsl(100%, 100%, 100%)" & @CRLF & _
"hsl(100%, 100%, 100%, 1009)" & @CRLF & _
"hsl(0,0,0,1.2)" & @CRLF & _
"hsl(0, 0 , 0 , 1.2)" & @CRLF & _
"hsl(0,0,0, 0.4)" & @CRLF & _
"hsl(0,0,0, 0.499)" & @CRLF & _
"hsl(0, 0 , 0 )" & @CRLF & _
"hsla(0, 0, 0, 1)" & @CRLF & _
"hsla(0, 0, 0, .45)" & @CRLF & _
"hsla(0, 0, 0, .4)" & @CRLF & _
"hsla(0,0,0, 1.2)" & @CRLF & _
"hsla(100%, 100%, 100%, 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")