import Foundation
let pattern = ##"^#(?:[\da-f]{3}){1,2}$|^#(?:[\da-f]{4}){1,2}$|(rgb|hsl)a?\((\s*-?\d+%?\s*,){2}(\s*-?\d+%?\s*)\)|(rgb|hsl)a?\((\s*-?\d+%?\s*,){3}\s*(0|(0?\.\d+)|1)\)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
#ff0
#ff00
#ff00f
#ff00ff
#ff00ff0
#ff00ff00
rgb(0, 0, 0)
rgb(0,)
rgb(0 0)
rgb( 0, 0, 0 )
rgb(-100, -10, 0 )
rgb(0, 0, 0,)
rgb(-100, -10 0 )
rgb(-100 -10 0 , , ,)
rgb(100%, 100%, 100%)
hsl(100%, 100%, 100%, 1009)
rgb(0,0,0,1.2)
rgb(0, 0 , 0 , 1.2)
rgb(0,0,0, 0.4)
rgb(0,0,0, 0.499)
rgb(0, 0 , 0 )
rgba(0, 0, 0, 1)
rgba(0, 0, 0, 0)
rgba( 0, 0, 0, 1)
rgba(0, 0, 0, .45)
rgba(0, 0, 0, .4)
rgba(0,0,0, 1.2)
rgba(100%, 100%, 100%, 1)
hsl(0, 0, 0)
hsl(0,)
hsl(0 0)
hsl( 0, 0, 0 )
hsl(-100, -10, 0 )
hsl(-100 , -10, 0 )
hsl(0, 0, 0,)
hsl(-100, -10 0 )
hsl(-100 -10 0 , , ,)
hsl(100%, 100%, 100%)
hsl(100%, 100%, 100%, 1009)
hsl(0,0,0,1.2)
hsl(0, 0 , 0 , 1.2)
hsl(0,0,0, 0.4)
hsl(0,0,0, 0.499)
hsl(0, 0 , 0 )
hsla(0, 0, 0, 1)
hsla(0, 0, 0, .45)
hsla(0, 0, 0, .4)
hsla(0,0,0, 1.2)
hsla(100%, 100%, 100%, 1)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)