package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^#(?:[\da-f]{3}){1,2}$|^#(?:[\da-f]{4}){1,2}$|(rgb|hsl)a?\((\s*-?\d+%?\s*,){2}(\s*-?\d+%?\s*)\)|(rgb|hsl)a?\((\s*-?\d+%?\s*,){3}\s*(0|(0?\.\d+)|1)\)`)
var str = `#ff0
#ff00
#ff00f
#ff00ff
#ff00ff0
#ff00ff00
rgb(0, 0, 0)
rgb(0,)
rgb(0 0)
rgb( 0, 0, 0 )
rgb(-100, -10, 0 )
rgb(0, 0, 0,)
rgb(-100, -10 0 )
rgb(-100 -10 0 , , ,)
rgb(100%, 100%, 100%)
hsl(100%, 100%, 100%, 1009)
rgb(0,0,0,1.2)
rgb(0, 0 , 0 , 1.2)
rgb(0,0,0, 0.4)
rgb(0,0,0, 0.499)
rgb(0, 0 , 0 )
rgba(0, 0, 0, 1)
rgba(0, 0, 0, 0)
rgba( 0, 0, 0, 1)
rgba(0, 0, 0, .45)
rgba(0, 0, 0, .4)
rgba(0,0,0, 1.2)
rgba(100%, 100%, 100%, 1)
hsl(0, 0, 0)
hsl(0,)
hsl(0 0)
hsl( 0, 0, 0 )
hsl(-100, -10, 0 )
hsl(-100 , -10, 0 )
hsl(0, 0, 0,)
hsl(-100, -10 0 )
hsl(-100 -10 0 , , ,)
hsl(100%, 100%, 100%)
hsl(100%, 100%, 100%, 1009)
hsl(0,0,0,1.2)
hsl(0, 0 , 0 , 1.2)
hsl(0,0,0, 0.4)
hsl(0,0,0, 0.499)
hsl(0, 0 , 0 )
hsla(0, 0, 0, 1)
hsla(0, 0, 0, .45)
hsla(0, 0, 0, .4)
hsla(0,0,0, 1.2)
hsla(100%, 100%, 100%, 1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}