package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\d{4})(-| )(\d{3})(-| )(\d{4})|((04|\+61)(\d{10}|\d{9}|\d{8}))|((04|\+04|61|\+61)( |-)(\d{1})( |-)(\d{4}|\d{3})( |-)(\d{4}|\d{3})))`)
var str = `regex australian phone number format (e.g. 0412-123-4567) or (e.g. 0412 123 4567) or (e.g. 0412-123 4567) or (e.g. 0412345678) or (e.g. +61 4 1234 5678) or (e.g. +61 4 1234 567) or (e.g. +6101234567) or (e.g. +61012345678)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}