use strict;
my $str = 'regex australian phone number format (e.g. 0412-123-4567) or (e.g. 0412 123 4567) or (e.g. 0412-123 4567) or (e.g. 0412345678) or (e.g. +61 4 1234 5678) or (e.g. +61 4 1234 567) or (e.g. +6101234567) or (e.g. +61012345678)';
my $regex = qr/((\d{4})(-| )(\d{3})(-| )(\d{4})|((04|\+61)(\d{10}|\d{9}|\d{8}))|((04|\+04|61|\+61)( |-)(\d{1})( |-)(\d{4}|\d{3})( |-)(\d{4}|\d{3})))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}