const regex = /(?:^|[^\d])(\d{10})(?:[^\d]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\\d])(\\d{10})(?:[^\\d]|$)', 'gm')
const str = `text 0123456789 text 0123456789
012345678912 text 0123456789
0123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}