$re = '/(?:^|[^\d])(\d{10})(?:[^\d]|$)/m';
$str = 'text 0123456789 text 0123456789
012345678912 text 0123456789
0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);