re = /(?:^|[^\d])(\d{10})(?:[^\d]|$)/m
str = 'text 0123456789 text 0123456789
012345678912 text 0123456789
0123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end