using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([^#]*)#=([^#]*)(?:;|$)";
string input = @"#aaaa#=1111;#bbbbb#=2222;#cccc#=33;333;#cccc#=33;333";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}