$re = '/#([^#]*)#=([^#]*)(?:;|$)/';
$str = '#aaaa#=1111;#bbbbb#=2222;#cccc#=33;333;#cccc#=33;333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);