use strict;
my $str = '01.23.45.67.89
02.33.44.55.66
05.00.00.00.00
';
my $regex = qr/^(\d)(\d)\.(\d\d)\.(\d\d)\.(\d\d)\.(\d\d)$/mp;
my $subst = '<a href="33$2$3$4$5$6">$0</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";