$re = '/^(\d)(\d)\.(\d\d)\.(\d\d)\.(\d\d)\.(\d\d)$/m';
$str = '01.23.45.67.89
02.33.44.55.66
05.00.00.00.00
';
$subst = "<a href=\"33$2$3$4$5$6\">$0</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;