re = /^(\d)(\d)\.(\d\d)\.(\d\d)\.(\d\d)\.(\d\d)$/m
str = '01.23.45.67.89
02.33.44.55.66
05.00.00.00.00
'
subst = '<a href="33$2$3$4$5$6">$0</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result